[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4762: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4764: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4765: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4766: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
GTXBASE • View topic - GTK 3.0 no compatible con T-Gtk 2.0
It is currently Sat Dec 14, 2019 10:43 pm

All times are UTC




 Page 1 of 2 [ 13 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: GTK 3.0 no compatible con T-Gtk 2.0
PostPosted: Thu Jan 03, 2013 3:23 pm 

Joined: Thu Dec 30, 2010 8:46 pm
Posts: 92
Actualmente, T-Gtk 2.0, no es compatible con GTK 3.0, puesto que han cambiando / quitado muchas
funciones del API antiguo.

Si instaláis UBUNTU 12.04, o similar, que trae GTK3.0, T-GTK actual NO FUNCIONA.

De momento he localizado algunas cosas, pero va a ser un trabajo de chinos.


Offline
 Profile Send private message  
 
 Post subject: Re: GTK 3.0 no compatible con T-Gtk 2.0
PostPosted: Sat Jul 20, 2013 7:10 pm 

Joined: Thu Dec 30, 2010 12:18 am
Posts: 92
Hola, poco después de has creado la rama para gtk3 he estado revisando y modificando con la intension de de ir migrando t-gtk.

Ya he realizado los cambios correpondientes en los makefiles.. y estoy trabajando con /hbgtk/*.c

He estado pensando en varios escenarios:

- Será sano o necesario plantear t-gtk3 como "no compatible" con gtk2 e ir limpiando el código?

- Será mejor mantener la compatibilidad...?

- Respecto a harbour... buscamos utilizar hbmk2?

Todo esto lo comento porque por lo visto hay que revisar casi toda la fuente de t-gtk con lupa y hay algunos elementos que creo desaparecerán en caso de compilar con gtk3.

Sin más por el momento...

Saludos
Riztan


Offline
 Profile Send private message  
 
 Post subject: Re: GTK 3.0 no compatible con T-Gtk 2.0
PostPosted: Mon Jul 22, 2013 8:08 am 

Joined: Thu Dec 30, 2010 8:46 pm
Posts: 92
>Hola, poco después de has creado la rama para gtk3 he estado revisando y modificando con la intension de de ir migrando t-gtk.

Hola Riztan. Mi intención a usar Git es porque me dí cuenta que nos permite una flexibilidad enorme.
De esta manera crear una rama de desarrollo gtk3 paralela a la rama master, nos permite tener la compatibilidad de gtk2 , pero
podemos seguir trabajando en gtk3, sin molestar a nadie.
Decidí crear la rama gtk3, porque hay que realizar multitud de cambios, tanto a nivel de prg como de C, porque ya muchos cambios
significativos, y muchas cosas se dejaron de usar

>Ya he realizado los cambios correspondientes en los makefiles.. y estoy trabajando con /hbgtk/*.c
Okis. Ya vi los cambios que has realizado.
Para que puedas ver los cambios en los ficheros fácilmente ; git diff b18977f2 gtk3 --stat
Esto nos muestra en forma de estadísticas, que ficheros han cambiado desde el commit b18977f2 con respecto a la rama gtk3.
No entendí el log "Mil disculpas.." jajaja, ahora sé lo que hiciste.

>He estado pensando en varios escenarios:
> Será sano o necesario plantear t-gtk3 como "no compatible" con gtk2 e ir limpiando el código?
> Será mejor mantener la compatibilidad...?

Este a sido mi dilema.

El problema es que si lo hacemos "no compatible", ¿ Que hacemos con la gente que usa gtk2 ?

Yo creo que con los defines y la compilación condicional , podemos mantener las 2 versiones, al menos de momento.

Estoy usando Ubuntu 10.04, y no voy a cambiar porque el proyecto que estoy realizando está ya al 90% de terminar.
En Windows tengo el instalador que funciona con Gtk2.

¿ Voy a empezar de cero ? NO

Mi voto es al menos, es mantener la compatibilidad a toda costa. La rama master, podemos tenerla como hasta ahora.

La rama gtk3, podemos usar 2 enfoques;

1- Mantener la compatibilidad con gtk2, e ir fusionando con la master los cambios, aunque no aporte nada a Gtk2,
pero esto nos permite usar la rama master para construir gtk2 o gtk3, según los Makes, como hasta ahora.

2- Usar exclusivamente la rama gtk3, para el desarrollo único de gtk3, rompiendo la compatibilidad con gtk2.
Esta forma nos facilitaría a la hora de desarrollar, porque cosas que no estén en el API se borran y punto.

Mi idea inicial fue usar la opción uno, pero con el tiempo , no le veo sentido, por la sencilla razón que un simple, git checkout gtk3
tenemos el código fuente de gtk3 listo para compilar.

Esto tiene como contrapartida, que será casi imposible fusionar ambas ramas por la gran cantidad de divergencias que vamos a encontrar,
que no me preocupa lo más mínimo, pero llegado el dia, tendremos que dar el cambiazo, crear la rama gtk2 a partir de la rama master,
y llevar todo gtk3 a la rama master, a partir de ese momento podemos usar la rama master para gtk3.

Ahora bien, esto puede ocasionarle a más de uno un "trastorno" ;-)

>- Respecto a harbour... buscamos utilizar hbmk2?
Sinceramente Riztan, el montaje que hiciste, un gran trabajo por otra parte, para mí, es demasiado complicado.
La idea original fue Rules.make, un fichero simple de mantener, aunque es cierto, que cuando empecé a lo que habeis incorporado
no tiene nada que ver, y lo mejora mil veces.

Yo voto por usar hbmk2, pero es he aquí el problema.
¿ Que pasa con xharbour ? Particularmente yo no lo uso, sinceramente, Harbour a superado a xharbour en casi todos los aspectos.
Hasta Xailer, que en su día apostaron por xharbour han cambiado.

>Todo esto lo comento porque por lo visto hay que revisar casi toda la fuente de t-gtk con lupa y hay algunos elementos que creo desaparecerán en caso de compilar con gtk3.

Es lo que estado haciendo. Me dí cuenta del gran esfuerzo que hay que realizar, y sinceramente, no sé si merecerá la pena.
Quizás tengamos que definir que es lo que queremos hacer con t-gtk para el futuro.

Saludos desde vacaciones ;-)


Offline
 Profile Send private message  
 
 Post subject: Re: GTK 3.0 no compatible con T-Gtk 2.0
PostPosted: Fri Jul 26, 2013 5:00 am 

Joined: Thu Dec 30, 2010 12:18 am
Posts: 92


Offline
 Profile Send private message  
 
 Post subject: Re: GTK 3.0 no compatible con T-Gtk 2.0
PostPosted: Fri Jul 26, 2013 6:24 am 

Joined: Thu Dec 30, 2010 12:18 am
Posts: 92
Rafa, si tienes algun tiempito...

http://www.webupd8.org/2013/06/how-to-i ... .html#more

Hasta los momentos me ha funcionado de maravilla en una virtual con lubuntu 13.04

No podia ir a dormir sin verificar esto primero... ahora si. :)

Saludos!


Offline
 Profile Send private message  
 
 Post subject: Re: GTK 3.0 no compatible con T-Gtk 2.0
PostPosted: Fri Aug 02, 2013 1:01 am 

Joined: Thu Feb 16, 2012 1:41 am
Posts: 34


Offline
 Profile Send private message  
 
 Post subject: Re: GTK 3.0 no compatible con T-Gtk 2.0
PostPosted: Fri Aug 02, 2013 5:58 am 

Joined: Thu Dec 30, 2010 12:18 am
Posts: 92


Offline
 Profile Send private message  
 
 Post subject: Re: GTK 3.0 no compatible con T-Gtk 2.0
PostPosted: Sun Aug 04, 2013 4:28 pm 

Joined: Thu Dec 30, 2010 8:46 pm
Posts: 92
Buenas Javier

Mi comentario anterior no significa que vaya a desaparecer T-GTK, ¿ Como va a desaparecer algo que es tuyo ? ;-)

La idea es básicamente es que hacer en un futuro cercano.
Creo que con lo que hay realizado en T-GTK 2, es suficiente para poder abarcar cualquier tipo de aplicación.

El problema se presenta con GTK3.
Es una ardua tarea, y la verdad sea dicha, somos pocos con los conocimientos necesarios para abordarlo, y necesitamos sumar esfuerzos.

Que yo conozca hay 3 librerías de Harbour para GTK+:
+ T-Gtk
+ FiveLinux
+ xhgtk

Todas son libres, entonces ;
¿ Porque no hacer un esfuerzo e intentamos unir todas en una ?
¿ Tiene sentido tener 3 librerías que hacen lo mismo ?

Se me pasa por la mente el poder fusionar los 3 proyectos en uno solo para GTK3, aunque es solo una idea, mi intención es intentar dialogar
con los responsable de los proyectos para ver que posibilidades hay reales de hacer una fusión.
A Antonio Linares lo llamo por teléfono y termino antes ;-), en resto, conozco a Sandro, pero no sé en qué estado se encuentra actualmente dicha librería.

Ahora con esta idea , tenemos que mirar como encajar estas 3 librerías.

Saludos


Offline
 Profile Send private message  
 
 Post subject: Re: GTK 3.0 no compatible con T-Gtk 2.0
PostPosted: Wed Aug 07, 2013 3:14 am 

Joined: Thu Feb 16, 2012 1:41 am
Posts: 34
Hola Rafa/Riztan,

Gracias por sus comentarios...

Bueno igual me exprese mal, con "desaparecer" me refería al soporte de ustedes..., ya que te escuche muy "desilusionado", me supongo por el número de usuarios de T-Gtk, y con tus palabras de "valdrá la pena"...

Esa fue mi preocupación y como yo ni he aterrizado esto en una aplicación, pues me puse nervioso...

Pero agradezco sus comentarios..., estaré atento a ver qué deciden y qué rumbo toman las cosas...

Saludos,
Javier


Offline
 Profile Send private message  
 
 Post subject: Re: GTK 3.0 no compatible con T-Gtk 2.0
PostPosted: Sat Aug 10, 2013 4:20 am 

Joined: Thu Dec 30, 2010 12:18 am
Posts: 92


Offline
 Profile Send private message  
 
Display posts from previous:  Sort by  
 Page 1 of 2 [ 13 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron