[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4762: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4764: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4765: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4766: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
GTXBASE • View topic - Instalador Version 2.0 ya disponible..
It is currently Sat Dec 14, 2019 10:44 pm

All times are UTC




 Page 1 of 4 [ 37 posts ]  Go to page 1, 2, 3, 4  Next
Author Message
 Post subject: Instalador Version 2.0 ya disponible..
PostPosted: Fri May 13, 2011 5:26 am 

Joined: Thu Dec 30, 2010 12:18 am
Posts: 92
Amigos,

Después de un largo periodo de tratar de automatizar la instalación de t-gtk bajo Windows y facilitar la generación del script del instalador....

Tras varias pruebas de funcionamiento...

Ya están a disposición dos instaladores de la versión 2.0 de t-gtk.

instalador básico: Solo incluye t-gtk con las librerias compiladas, más wget y 7zip para descarga y descompresión de ficheros...

instalador full: (recomendado) t-gtk, tdolphin, gtk+, glade, mingw, harbour (binarios y fuentes)...


Con respecto al instalador full... solicita grabar los componentes (gtk+,glade y mingw) en el directorio de destino para MinGW (recomendado). Esto para no tener necesidad de crear múltiples rutas en el path. El instalador, registra esta ruta en el path al finalizar el proceso... por lo que luego de instalar, solo hay que hacer... make ;)

El instalador básico, requiere que el archivo setenv.mk sea editado indicando las rutas de los componentes... y tener seteadas las rutas de MinGW y GTK+ en el path...

Si setean la variable de entorno AUTO_INST=yes se activa en las rutinas la posibilidad de intentar "descargar" con wget y "descomprimir" con 7zip los componentes externos (gtk+, glade, y sus respectivas dependencias...)

Si no se activa la descarga... pueden setear igualmente TGTK_DOWN=yes
Si no se activa la descompresion... pueden setear igualmente TGTK_UNZIP=yes

Este proceso, se realiza una sola vez... para poder volver a ejecutarlo, deberan eliminar del directorio config los archivos o ficheros de extension .log

NOTA: Vuelvo a recordar... esto solo tiene efecto para Windows... (en GNU/Linux no es necesario...)

Espero sea esto de utilidad...


Saludos!!


Offline
 Profile Send private message  
 
 Post subject: Re: Instalador Version 2.0 ya disponible..
PostPosted: Fri May 13, 2011 7:08 am 

Joined: Thu Dec 30, 2010 8:46 pm
Posts: 92
Grande Riztan!
Muchas gracias


Offline
 Profile Send private message  
 
 Post subject: Re: Instalador Version 2.0 ya disponible..
PostPosted: Thu May 19, 2011 2:56 am 

Joined: Wed May 18, 2011 8:07 pm
Posts: 8
Hola Riztan, he instalado la version 2 de t-gtk en Win7Ult 64bits, despues de configurar, pruebo los ejemplos de la carpeta abm y browses, en ambos casos me genera el EXE, pero estos cargan, e inmediatamente dejan de funcionar mostrandome esta ventana:

Salu2,
GVS


Attachments:
moz-screenshot-4.png
moz-screenshot-4.png [ 39.77 KiB | Viewed 18164 times ]
moz-screenshot-3.png
moz-screenshot-3.png [ 54.83 KiB | Viewed 18164 times ]
Offline
 Profile Send private message  
 
 Post subject: Re: Instalador Version 2.0 ya disponible..
PostPosted: Thu May 19, 2011 3:36 am 

Joined: Thu Dec 30, 2010 12:18 am
Posts: 92
Hola Guillermo!

Oye... yo aún no he realizado las pruebas bajo Windows a 64bits.... lo tendré pendiente.

Los otros ejemplos te funcionan?

saludos!


Offline
 Profile Send private message  
 
 Post subject: Re: Instalador Version 2.0 ya disponible..
PostPosted: Thu May 19, 2011 4:03 am 

Joined: Wed May 18, 2011 8:07 pm
Posts: 8


Offline
 Profile Send private message  
 
 Post subject: Re: Instalador Version 2.0 ya disponible..
PostPosted: Thu May 19, 2011 5:14 am 

Joined: Thu Dec 30, 2010 12:18 am
Posts: 92


Offline
 Profile Send private message  
 
 Post subject: Re: Instalador Version 2.0 ya disponible..
PostPosted: Thu May 19, 2011 12:00 pm 

Joined: Thu Dec 30, 2010 8:46 pm
Posts: 92
Amigos, en 64 bits hay un bug en los browses de t-gtk.
Hay un #ifndef __HARBOUR64__ en gtkbrowse.c , la funcion gtk_paint_box() se rompe, no logré entender porque,
pero hice ese patch para poder usarlo;

// Caja tipo 'boton' para headers
/*TODO:
Existe un bug en Harbour 64 , falla el paso del parámetro widget->style
*/

#ifndef __HARBOUR64__

solamente tienen que añadir a sus make , para versiones de 64, ese define.

Saludos


Offline
 Profile Send private message  
 
 Post subject: Re: Instalador Version 2.0 ya disponible..
PostPosted: Thu May 19, 2011 12:10 pm 

Joined: Thu Dec 30, 2010 8:46 pm
Posts: 92
En tema de la impresión, esta el soporte nativo, hay un ejemplo de ello en /native/print/gtkprint.prg


Offline
 Profile Send private message  
 
 Post subject: Re: Instalador Version 2.0 ya disponible..
PostPosted: Thu May 19, 2011 12:29 pm 

Joined: Wed May 18, 2011 8:07 pm
Posts: 8
Muchas gracias Riztan por tu tiempo y respuestas.


Bueno, con los cambios realizados últimamente, ha perdido vigencia... pero hay que actualizarlo. ;)

Si observas el Rules.make ahora es un tanto diferente y no es necesario modificarlo... y se agregaron un conjunto de rutinas en config/ para realizar toda la revisión/configuración... de manera que solo modifiquemos el setenv.mk para ajustar a nuestro entorno.. :)


Ah ya, bueno, con la desesperación de ver funcionando a t-gtk, comence a modificar otros archivos de config, hasta que finalmente me quede con un mensaje que me decia que no encontraba la ruta del pkg-config, asi que la agregue a mi PATH manualmente y tuve que hacerlo exactamente como lo habia definido en el archivo config que habia modificado, es decir, si yo agregaba al PATH c:\ABC y si habia definido \abc, no aceptaba \ABC, pero bueno, voy a tratar de dejar config como viene y ver si moviendo setenv.mk trabaja.

Otra pregunta, que archivos debo incluir para instalar un EXE en una maquina cliente que no tiene t-gtk ni nada, solo tiene WinXP

De antemano, muchas gracias.

Salu2,
GVS


Offline
 Profile Send private message  
 
 Post subject: Re: Instalador Version 2.0 ya disponible..
PostPosted: Thu May 19, 2011 12:44 pm 

Joined: Wed May 18, 2011 8:07 pm
Posts: 8


Offline
 Profile Send private message  
 
Display posts from previous:  Sort by  
 Page 1 of 4 [ 37 posts ]  Go to page 1, 2, 3, 4  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron